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1 Mousing

First, how do we move around and select things?

Left-mouse Drag Rotate view
Ctrl Left-Mouse Drag Translates view
Shift Left-Mouse Label Atom
Right-Mouse Drag Zoom in and out
Middle-mouse Centre on atom
Scroll-wheel Forward Increase map contour level
Scroll-wheel Backward Decrease map contour level

2 Getting Started

In this tutorial, we will learn how to do the following:

1. Start Coot

2. Display coordinates

3. Display a map

4. Zoom in and out

5. Recentre on Different Atoms

6. Change the Clipping (Slab)

7. Recontour the Map

8. Change the Map Colour

9. Display rotamers and refine residue

2.1 Load tutorial data

Launch coot from a terminal window, by typing:
$ coot

(In the CCP4 Cloud, it’s different - there one starts Coot from an established
project. We don’t need to do that for this tutorial.)

So let’s read in the coordinates and data (and thus generate a map)
To load the files on which we will be working:
From Coot’s main menu bar, select Calculate → Load tutorial model and

data
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2.2 Adjust Virtual Trackball

By default, Coot has a “virtual trackball” to relate the rotation of the molecule
to the movement of the mouse. The default is to act like PyMOL - some people
don’t like this.

So you might like to try the following. From the Coot main menu-bar:
Edit → Preferences. . .
[Coot displays a Preferences window]

On the left toolbar select General (it should be selected by default) and then
on the right top notebook tab HID. (You may need to resize the window or use
the arrow in the top right to get to this tab.) Select “Turntable Mode (Flat)” to
change the mouse movement. (If you wish, you can use the “Spherical Surface”
option to turn it back to how it is by default).

What is the difference? In both modes, dragging the mouse near the centre
of the screen causes the view to rotate about the X- or Y- axis. However in
Spherical Surface mode you can also rotate about the z-axis by dragging the
mouse along an edge of the window.

2.3 Zoom in and out

To zoom in, click Right-mouse and drag it left-to-right1. To zoom out again,
move the mouse the opposite way.

2.4 Recentre on Different Atoms

• Select “Draw” from the Coot menu-bar

• Select “Go To Atom. . . ”

[Coot displays the Go To Atom window]

• Expand the tree for the “A” chain

• Select 1 ASP in the residue list

• Click “Apply” in the Go To Atom window

• Use “Next Residue” and “Previous Residue” (or, alternatively use “Space”
and “Shift” “Space” on the keyboard in the graphics window) to move
along the chain.

• To recentre click middle-mouse over an atom in the graphics window

[Coot recentres on that atom]

• Ctrl Left-mouse & Drag moves the view around. Normally, this should
happend comfortably fast enough. If you have a slower computer how-
ever, this can be too slow and jerky, in that case you can adjust your set-
tings:

1or up-to-down, if you prefer that
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Figure 1: Coot after reading an MTZ file and zoomed in. Note that the back-
ground colour here is white (this has been done to preserve ink). You can use
Edit → Background Colour to change the background colour if you wish.
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– Select Edit → Preferences. . . from Coot’s menu-bar

– Select the “Maps” toolbutton on the left

– Select the “Dragged Map” notebook tab.

– Select “No” in the “Active Map on Dragging” window

– Click “OK” in the “Preferences” window

Now the map is recontoured at the end of the drag, not at each step2.

Another, additional way to make the movements faster is to change the
number of steps for the “Smooth Recentering”. Again you find this in the
“Preferences” (Preferences → General → Smooth Recentering). Change
the “Number of Steps” (the default is 40) to something smaller, e.g. 20.

Coot’s Go To Atom Window (it doesn’t look exactly like this any more).

• You can display the contacts too, as you do this:

– Select “Measures” from the Coot menu-bar

– Select “Environment Distances. . . ”

– Click on the “Show Residue Environment?” check-button

∗ Also Click “Label Atom?” if you wish the Cα atoms of the residues
to be labelled.

2which looks less good on faster computers.
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– Click “OK” in the Environment Distances window

– Click “Apply” in the Go To Atom window

[You can’t change the colour of the Environment distances]

Figure 2: Coot showing Atom Label and environment distances.

You can turn off the Environment distances if you like (I recommend that
you do).

2.5 Change the Clipping (Slab)

You can use

“D” and “F”3 on the keyboard, or

Control Right-mouse up/down4.

Alternatively,

3think: Depth of Field.
4Control Right-mouse left/right does z-translation
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• Select “Draw” from the Coot menu-bar

• Select “Clipping. . . ” from the sub-menu

[Coot displays a Clipping window]

• Adjust the slider to the clipping of your choice

• Click “OK” in the Clipping window

2.6 Recontour the Map

• Scroll your scroll-wheel forwards one click5

[Coot recontours the map using a 0.05electron/Å3 higher contour level]

• Scroll your scroll-wheel forwards and backwards more notches and see
the contour level changing.

• If you don’t have a wheel on your mouse you can use “+” and “-” on the
keyboard.

• Note that the “Scroll” button in the Display Manager allows you to select
which map is affected by this6.

• Note that if you want to use the trackpad on a MacBook, then see the
Coot FAQ for how to set that up.

2.7 Change the Map Colour

• Select “Edit” from the Coot menu-bar

• Select “Map Colour” in the sub-menu

• Select “1 xxx FWT PHWT” in the sub-menu

[Coot displays a Map Colour Selection window]

• Choose a new colour by clicking on the colour widgets

[Coot changes the map colour to match the selection ]

• Click “OK” in the Map Colour Selection window

Alternatively you can get to the same dialog using the “Properties” button
in the Display Manager.

5don’t click it down.
6by default it is the last map, which is not necessarily the map that you want.
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2.8 Select a Map

Select a map for model building. There is a “Map” button displayed on the
right side of the Coot window in the vertical modelling toolbar. Note: If you
are not sure which icon corresponds to which function look at the displayed
tips when over the button with the mouse. Or change the display style of the
buttons by clicking on the bottom arrow and select another style to get only or
additionally text displayed.

Right Toolbar: “Map” from the Modelling Toolbar

click “OK” (you want to select the map with “. . . FWT PHWT”)
In the current example there is only one 2Fo-Fc-style map, so there’s not

much choice for the map.
You can set the map weight from this dialog if you wish. 60 is fine for this

tutorial.

3 Model Building

“So what’s wrong with this structure?” you might ask.
There are several ways to analyse structural problems and some of them

are available in Coot.

Validate → Density Fit Analysis → tutorial-modern.pdb
[Coot displays a bar graph]

Look at the graph. The bigger and redder the bar the worse the geometry.
There are 2 area of outstanding badness in the A chain, around 41A and 89A.

Let’s look at 89A first - click on the block for 89A.

[Coot moves the view so that 89A CA is at the centre of the screen ]

3.1 Rotamers

• Examine the situation. . . [ The sidechain is pointing the wrong way. Let’s Fix
it...]

• Modelling Toolbar: Select the “Rotamers” button

• In the graphics window, (left-mouse) click on an atom of residue 89A (the
Cγ, say)

[Coot displays the “Select Rotamer” window]

• Choose the Rotamer that most closely puts the atoms into the side-chain
density

• Click “Accept” in the “Select Rotamer” window

[Coot updates the coordinates to the selected rotamer]
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• Click “Real Space Refine Zone” in the vertical Modelling toolbar

• In the graphics window, click on an atom of residue 89A. Click it again.

[Coot displays the refined coordinates in white in the graphics and a
new “Accept Refinement” window]

• Click “Accept” in the “Accept Refinement” window.

[Coot updates the coordinates to the refined coordinates. 89A now fits
the density nicely.]

OK. That’s good.
Now, how about if we just use Real Space Refinement only?

• Click “Undo” twice

[Coot puts the sidechain back to the original position]

• Click “Real Space Refine Zone” in the Modelling Toolbar

• In the graphics window, click on an atom of residue 89A. Click it again.

[Coot displays the refined coordinates in white in the graphics and a
new “Accept Refinement” window]

• Now using left-mouse, click and drag on the intermediate (pale-coloured)
CZ atom of the PHE (if you mis-click the atom, the view will rotate).

• Can you pull the atom around so that the side-chain fits the density?

[Yes, you can]

3.2 More Real Space Refinement

Now let’s have a look at the other region of outstanding badness:

• Click on the graph block for 41 A

[Coot moves the view so that 41A CA is at the centre of the screen]

• Examine the situation. . .

• Residue 41 is in a mess and not fitting to the density. Can you fix it?

[Yes, you can]

• The trick is Real Space Refine that zone. So. . .

• You can either Real Space Refine a few residues (40, 41 and 42) or just 41.
Take your pick.

• Click on “Real Space Refine Zone” in the Modelling Toolbar

9



Figure 3: 89A now fits the density nicely.
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• Select a range by clicking on atoms in the graphics window (either atoms
in 40 then 42 or an atom in 41 twice)

[Coot displays intermediate (white) atoms]

• Click and drag on some atoms until the atoms fit nicely in the density.

If you want to move a single atom then Ctrl Left-mouse to pick and move
(just) that intermediate atom.

[Note: Selecting and moving just the Carbonyl Oxygen is a good idea - use Ctrl
Left-mouse to move just one atom.]

3.3 Saving

Use “Ctrl-S” for “Quick Save As” (you don’t get to choose the file name, coot
will make a file-name for you, using an increasing index so that previous ver-
sions are not over-written.

3.4 Display Symmetry Atoms

From the main menubar, select “Draw” → “Cell & Symmetry” and then

• Click the Symmetry On radiobutton

• Check the Always On checkbutton if you always want symmetry and
never want to be asked again.

4 Blobology

4.1 Find Blobs

To be found under Validate (called “Unmodelled Blobs”).
You can use the defaults in the subsequent dialog. Press “Find Blobs”. You

will get a new window that tell you that it has found unexplaned blobs sorted
by size (biggest first). Time to find out what they are...

4.2 Blob 3

Let’s start from Blob 3 and 4 (if you have it)

• Click on “Blob 3”

[Coot centres the screen on a blob]

• Examine the situation. . .

[We need to add something tetrahedral to the model there. . . ]

• “Place Atom At Pointer” on the Modelling Toolbar

[Coot shows a Pointer Atom Type window]

11



• “SO4” in the new window. . . 7

• Click OK.

• Examine the situation. . .

• the orientation is not quite right.

• Let’s Real Space Refine it (you should know what to do by now. . . )

• (“Real Space Refine Zone” then click an atom in the SO4 twice. Click
“Accept”)

[The SO4 fits better now].

Blob 4 (if you see it) is like Blob 3 (isn’t it?)

4.3 Blob 2

Click on the button “Blob 2” and examine the density. Something is missing
from the model. What is it?

This protein and has been co-crystallized with its ligand substrate, 3’ guano-
sine monophosphate.

How do we add that?

• File → Seach Monomer library. . .

• Type guanosine mono phosphate in the entry. Each word compo-
nent is used to match the names of the compounds in the dictionary.

• Find the button for “3GP” and press it. . .

[3GP appears]

It is often easier to work without hydrogens, so let’s delete them for now

• “Delete. . . ” from the Modelling Toolbar

• “Hydrogens in Residue”

• click on an atom in 3GP

[Hydrogens disappear]

The 3GP is displaced from where we want it to be. Let’s do some ligand
fitting.

Let’s undisplay the reference 3GP so that it doesn’t obscure our view of
the results

In In Display Manager, uncheck the “Display” checkbutton for the molecule
“3GP from dict”

7Yes, a sulfate is not an atom
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• In the main menu-bar Ligands → Find Ligands. . .

• In the “Select Ligands” frame, click on the checkbutton for the ’3GP’ lig-
and. No need to use the “Flexible” option.

• Double-check the protein model and the map are the ones that you want
them to be (the defaults should be fine).

• In the Where to Search? frame, choose “Right Here”

• Click Find Ligands

You can adjust the position of the atoms of the ligand using Real Space
Refinement

• Click on an atom in the ligand

[Coot adds intermediate white atoms and Refinement dialog ]

• Now pull on the atoms until you are satisfied then press OK

If you like the solution, you can merge this ligand into the protein:

• Edit → Merge Molecules. . .

• Click (activate) “Fitted ligand #0-0” (if that is the one that you use for RSR
- it should be!)

• into Molecule:

tutorial-modern.pdb

• Merge

4.4 Blob 1

• Click on “Blob 1”

• Examine the situation. . . What is this density?

[We need to add residues to the C-terminus of the A chain.]

The missing residues are GLN, THR, CYS (QTC).

• Calculate → Fit Loop. . . Fit Loop by Rama Search. . .

[Coot pops-ups a Fit Loop dialog]

Add residue number 94 to 96 in the A chain.

The single letter codes of the extra residues are QTC

• Make sure that you can see the unmodelled density well, then click “Fit
Loop”

• Watch. . .
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• Examine the density fit.

[It should be fine, except at the C-terminus. We need to add an OXT
atom to the residue]

• Calculate → Other Modelling Tools. . .

• Add OXT to Residue. . .

• Check that it will be added to the correct model and chain (by deafult it
will be)

Add it

——————————————————
This is a far as I expect you to get.

——————————————————

5 Customise the Interface

You can add extra buttons to the interface:

• Move the curor to the right of the vertical separator in the horizontal tool
bar (to the right of the icon for the ligand)

• Right Mouse click

• Click on Manage Buttons (add, delete buttons)

• Click on the check-buttons for the extra tools you want to add (I like to
add “Sphere Refine +”, “Tandem Refine” and “Backrub Rotamers”

[Coot adds new Buttons for the selected functions in the horizontal tool-
bar]

• Click Apply

• Keyboard accelerators can be added using Edit → Settings → Install Tem-
plate Keybinding. . . (I believe that if you start Coot from the CCP4i2 in-
terface similar key-bindings will be added for you).

Additional new/different functions can be loaded from File → Curlew.
This changes the interface quite a bit. If there’s time, it would be useful to

run through these structural edits using the new buttons and keyboard accel-
erators.
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6 Extra Fun (if you have time)

6.1 Waters

Fit waters to the structure

• “Find Waters. . . ” in the Other Modelling Tools dialog

[Waters appear]

To check the waters:

• Click on “Measures” in the main menubar.

• Click on Environment Distances

• Click on the “Show Residue Environment?” check-button

• Change the distances as you like

• Use the Go To Atom widget to go to the first water (probably towards the
end of the list of residues in the water chain (it might be the “E” chain))

• Use the Spacebar to navigate to the next residue (and Shift Spacebar to
go backwards)

• If you don’t like the fast sliding8 you can turn it off (if you haven’t done
so already):

– Click Edit → Preferences. . . in the main menubar

– Click General → “Smooth Recentering...”

– Click “No”

6.2 Display Symmetry Atoms

More on symmetry - try:

• Show Symmetry Atoms? → Yes

• Symmetry as Calphas? [on]

• Colour symmetry by molecule [on]

• Symmetry Radius 30Å

• Colour Merge → 0.1

• Show Unit Cell? [on]

• OK

• Zoom out and have a look at how the molecules pack together.

8it’s not very good for water checking
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6.3 Working with NCS

The tutorial data has two-fold NCS. With good data it is interesting to investi-
gate the differences between the NCS copies. This may be done by comparing
the NCS related electron density, comparing the NCS related chains, or com-
paring the Ramachandran plots for related chains:

• Comparing the NCS related electron density.

Go to Calculate/NCS maps and select the first map and model. Now,
if you go to anywhere in the A chain, you will see two sets of electron
density - the original density for the A chain, and the density for the B
chain transformed to overlap the A chain density. This gives you a visual
comparison of any differences.

Look at the density in the B molecule. Why does the density not agree
here? (Hint: the NCS is not a 2-fold rotation in this case, it is improper).

• Comparing the NCS-related chains.

Go to Draw/NCS ghost control and select Display non-crystallographic
ghosts. You will now see a copy of the B chain superimposed on the
A chain. The B chain is draw using thin bonds.

Look for regions where the models differ. Using the NCS maps tool,
check that the differences in the models are supported by the density.

• Compare the NCS-related chains using “NCS jumping”.

This is an alternative way of examining NCS similarities and differences.
Use the Display Manager to undisplay the NCS maps you recently cre-
ated above.

Use the Goto Atom dialog and press the “Update from Current Position”
button.

[Coot shifts the centre of the screen to the closest displayed CA atom]

Identify the chain that you are looking at (for example, by double-clicking
on an atom)

Now press the “o” key on the keyboard.

[Coot shifts the centre of the screen to a NCS-related chain]

Identify the chain that you are looking at now.

Press “o” again.

What is happening?

(Note: ”o” stands for “Other NCS-related chain”.)

• Comparing the Ramachandran plots for related chains.

Go to Validate/Kleywegt plot. Check the Use specific chain options and
select chains A and B. You will get a Ramachandran plot with equivalent
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residues from the A and B chains linked by arrows. Long arrows indicate
significant differences. Click on a dot to view the residue concerned.

(After we have fixed up the structure, there is little to see here - to see a
problematic structure you can load the tutorial model again)

Another tool for identifying NCS differences is the Validate/NCS differ-
ences graph. This gives a clickable histogram of differences.

6.4 Add Terminal Residue

[To be found on the Modelling Toolbar9]

• Use the Go To Atom window to go to residue 72 A.

• What do you see?

[You see missing atoms (that is, you don’t see them). This residue is supposed to
be a CYS! Bad things have happened to it. Let’s get rid of this residue. ]

[There may also be waters in the side-chain positions too (they have to be removed
too).]

• Delete. . .

• (Make sure “Residue/Monomer” is active)

• Click on an atom of residue 72 A.

[Residue 72 A disappears]

• Let’s add back an ALA.

• Add Terminal Residue. . .

• Click in a atom in residue 71 (or 73)

[Coot adds an ALA]

OK, we now have a ALA. We want a CYS:

• Mutate & Auto Fit. . .

• Click on an atom in the new ALA

[Coot pops up a residue type chooser]

• Choose residue type CYS

[Coot mutates and fits a CYS]

• Examine the situation.

[ There is an extra blob of density on that CYS. What is it?] It is an alternative
conformation.

Let’s model it
9and in the Model/Fit/Refine window
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• Add Alt Conf. . .

[Coot pops up a residue splitter dialog]

• Choose how you want to split your residue - the default is fine

• Click on an atom in 72 A

[Coot adds intermediate white atoms and pops up a Rotamer Chooser]

• Choose the correct rotamer - it shouldn’t be difficult to tell which is the
closest.

• Accept when you are happy with you choice.

• Now optimize the fit of this new residue with Real Space Refinement.

The refinement of each alternate conformations is independent.

• Real Space Refine Zone

• click on (say) SG,B of 72A

• Press “A” (on the keyboard)

[Coot moves the atoms a bit]

• Accept

• Now do the same with the other conformation.

[Ahhh! Much better.]

6.5 Skeletonization and Baton Building

You can calculate the map skeleton in Coot directly:
Calculate → Map Skeleton... → On.
This can be used to “baton build” a map. You can turn off the coordinates

and try it if you like (the Baton Building window can be found by clicking “Ca
Baton Mode. . . ” in the Other Modelling Tools dialog10).

If you want to do this, I suggest you use Go To Atom and start residue 2 A
(this allows you to build the complete A chain in the correct direction (it takes
about 15 minutes or so) and you can compare it to the real structure afterwards.

Remember, when you start, you are placing a CA at the baton tip and at
the start you are placing atom CA 1. This might seem that you are “double-
backing” on yourself - which can be confusing the first time.

10this is quite advanced
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6.6 Make a Picture

(Depends on the appropriate supporting software11 being installed):

• Arrange a nice view

• Draw → Screenshot → Raster3D. . .

Accept the deafult file name. . .

• Wait a few seconds. . .

11Ethan Merritt’s Raster3D
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